CopyTo Synchronizer へようこそ

最新情報と最新バージョンのダウンロード http://www.kish-d.com/index-j.html

CopyTo Synchronizer Free Version 3
プレビュー表示、圧縮、世代管理バックアップ、複数フォルダにも対応したフォルダ同期、バックアップ、比較ツール

v3.31 (2010.10.01)
  • CopyTo Synchronizerはフリーウエアとして公開されました。

v3.30 (2010.06.06)

  • Windows 7に正式対応しました。
  • 64bit版Windows 7のシェル拡張(コンテキストメニュー)にも対応しました。
  • Windows 7でタスクバーのプログレスバー表示に対応しました。
    ※「タスクコントローラー」はVista以降のOSでその互換性を維持できないため、インストールされないように変更しました。

CopyTo Synchronizerは、豊富なオプションを持ち高機能でありながら、簡単な操作で軽快に動作するバックアップをメインとしたファイル処理ツールです。

特長

  • ファイルの更新や複数フォルダ間の同期処理を簡単な操作で安全かつ高速に行います。
  • 実際の処理前プレビューウインドウですべての処理内容を確認できますのでフォルダの指定間違いなど設定ミスを防止できます。
  • Unicode形式のファイル名に対応しました。名前に他国言語などUnicodeが含まれるファイルも処理可能となりました。
  • フォルダの指定やその他の豊富なオプションはプロジェクトファイルに保存することができます。その実行はプロジェクトを開くことで、設定変更はプロパティウインドウから簡単に変更することができます。
  • エクスプローラをシェル拡張し、コンテキストメニューからCopyToを起動することも可能です。これによりファイルやフォルダ指定が簡単になります。また、エクスプローラが本来持つコピー、移動、削除機能もCopyToにより処理することが可能です。

バックアップと同期機能

  • 同期処理、双方向バックアップ、差分バックアップ、増分バックアップ、ファイル比較など豊富な処理モードをサポート。
  • 複数フォルダをまとめて処理可能。
  • ターゲットフォルダの指定では処理実行時の日時に置換するマクロを使用可能。このマクロをフォルダ名に指定することにより、日付別のフォルダにバックアップすることもできます。
  • ネットワークフォルダを指定したとき接続アカウントが設定可能。
  • 実行時の優先度を指定することが可能ですので、バックグランドで負荷をかけずに実行できます。
  • コマンドラインから、複数のプロジェクトを連続して実行可能。
  • コピー後に処理元とターゲットのファイルの内容を比較することで正しくコピーできたかを検証することが可能。
  • 処理対象となるファイル、または対象から除くファイル、フォルダはワイルドカードで指定可能。
  • ファイルの置換時にファイル名に数字やファイルの更新日時を付加しての履歴保存する世代管理機能。
  • ZIP形式の圧縮でフォルダ単位にファイルを圧縮し、ディスク容量を節約する。
  • ZIP圧縮ファイル名に数字や更新日時を付加しての履歴保存が可能。
  • 実行前にドライブのボリュームラベルを照合することでメディアの間違いを警告。
  • 実行前と終了時に起動するプログラムを指定可能。

プレビューウインドウ

  • プレビューウィンドウではファイル単位に処理の中止や更新する向きを変更することが可能。
  • プレビューウィンドウからバイナリモードでファイルを連続比較できるので、ディレクトリ構造ごとファイルコンペアが可能です。
  • プレビューウィンドウのコンテキストメニューへ外部アプリケーションを登録。

バージョン３での主な改良点と追加機能について

  • 更新モードのバリエーションを追加
    従来のモードに加えて、「コピーバックアップ」、「フルバックアップ」、「差分バックアップ」、「ファイル比較」モードを追加しました。
  • プレビューなしのときの処理を効率化
     従来はプレビューをしないときも処理すべき内容をすべてリストアップ後、まとめて処理していたため、メモリを大量に使用していました。このため、処理ファイル数によってはメモリ不足となることもありました。　これをプレビューしないときはディレクトリ単位に随時処理するように変更することで、大量のファイルも処理することができるようになりました。
  • ファイル単位にコピー処理の進行状況を表示（Windows9X系では対応していません）
    ファイルのコピー中にもそのコピー状況が表示されるようになり、巨大なファイルでもコピー中にキャンセルできるようになりました。
  • 処理終了後も進行状況ダイアログを残す
    プロジェクトプロパティ（更新オプション）の設定により、処理終了後も進行状況ダイアログを残すことが可能となりました。
  • プロジェクトプロパティ（旧更新オプションなど）の操作性の向上
    旧バージョンで、数カ所に別れていたプロジェクトの設定を１カ所にまとめて、その一覧性や設定状況の把握を可能とし、操作性を向上させました。
  • プロジェクトプロパティに追加されたオプション
    • ネットワークフォルダを指定したとき接続アカウントが設定可能
    • 処理対象となるファイルがないときフォルダを作成しない（空のフォルダは作成されない）
    • 処理終了後も進行状況ダイアログを閉じないで残す
    • コピー後、コピーしたファイルの読みとり属性をオフにする(フォルダ圧縮時は無効)
    • コピー後、コピーしたファイルのNTFS圧縮属性をオンにする(NTFSドライブでのみ有効)
  • プロジェクトファイルの実行履歴を表示
    プロジェクトプロパティで、そのプロジェクトの実行履歴を表示することが可能となりました。


クリックスタート

１．プログラムの起動
  • インストールを行うとデスクトップと「スタートメニュー」のプログラムフォルダに「CopyTo Synchronizer」アイコンが作成されます。これらをダブルクリックすることでプログラムが起動します。
  • インストール時に[エクスプローラ シェル拡張]タブで「コンテキストメニューにCopyToを追加する」を有効にしたときはエクスプローラのコンテキストメニューから 起動することも可能です。
２．処理モード、ソースとターゲットフォルダの指定
  • フォルダタブにて処理モードを選択し、ソースとターゲットフォルダ名を入力します。
    各処理モードについて
    [メイン]画面
    [メイン]-[複数ファイルとフォルダの設定]
３．プロジェクトプロパティの設定
  • フォルダタブにて「プロパティ」ボタンで表示されるプロジェクトプロパティ画面で各種オプションを選択し、OKで画面を閉じます。
    [メイン]-[プロパティ]
４．プレビューを行い処理内容を確認する
  • フォルダタブにて「適用」ボタンを押すと、処理対象となるファイルの調査が始まり、しばらくするとプレビューウインドウが表示されます。
  • プレビューウインドウでプロジェクトプロパティで設定した内容が正しくリストアップされたかどうか確認し、問題があるときはもう一度、プロジェクトプロパティの内容を確認します。
    [プレビューウィンドウ]
５．プロジェクトファイルへ設定を保存
  • プロジェクトタブにて、プロジェクト名、保存フォルダ名を指定し、保存ボタンを押します。
  • 次回からは、エクスプローラでプロジェクトファイルをダブルクリックで開くことにより、すぐに処理がはじまります。
    [メイン]-[プロジェクト]
    プロジェクトファイルについて


各処理モードについて

処理モード名 処理内容 詳細と指定例
コピー ターゲットフォルダにコピーします
  • 選択したファイルやフォルダをターゲットフォルダ内へコピーします。フォルダを選択したときはサブフォルダも含めて、そのフォルダに含まれるすべてのファイルが処理されます。
  • 「コピー」「移動」「削除」モードではファイルの除外などのフィルター機能は利用できませんが、「C:\HOME\DOC\*.DOC」のようなワイルドカード指定は可能です。ただし、このときサブフォルダ内のファイルは対象になりません。
  • ソースにフォルダやファイルを複数指定し、ターゲットとなるフォルダが同じときは省略可能です。
書式１ |  | 例、C:\Favorites と C:\My Document を D:\Backup へコピーする
処理元 | <ソース1>;<ソース2>...<ソースn> | C:\Favorites;C:\My Document
ターゲット | <ターゲットフォルダ > | D:\Backup

書式２ |  | 例、C:\Favorites を D:\Backup\Favorites へ、C:\My Document を D:\Backup\My Document へコピー/移動する
処理元 | <ソース1>;<ソース2>...<ソースn> | C:\Favorites;C:\My Document
ターゲット | <ターゲットフォルダ1 >;<ターゲットフォルダ2 >...<ターゲットフォルダn > | D:\Backup\Favorites;D:\Backup\My Document
移動 ターゲットフォルダに移動します
  • 選択したファイルやフォルダをターゲットフォルダ内へ移動します。フォルダを選択したときはサブフォルダも含めて、そのフォルダに含まれるすべてのファイルが処理されます。
削除(ごみ箱に移動) ごみ箱に移動します(可能ならば)
  • 選択したファイルやフォルダをごみ箱へ移動します。
  • フォルダを選択したときはサブフォルダも含めて、そのフォルダに含まれるすべてのファイルが処理されます。
  • 「削除」モードではファイルの除外などのフィルター機能は利用できませんが、「C:\HOME\DOC\*.BAK」のようなワイルドカード指定は可能です。ただし、このときサブフォルダ内のファイルは対象になりません。
直接削除 ごみ箱に移動しないで直接削除します
  • 選択したファイルやフォルダをごみ箱に移動しないで、直接削除します。
  • フォルダを選択したときはサブフォルダも含めて、そのフォルダに含まれるすべてのファイルが処理されます。
バックアップ 新規作成ファイルと更新日時の新しいファイルをコピーします
  • ソースにだけ存在するファイルをターゲットフォルダにコピーします。
  • ソースとターゲットの両方に存在するファイルでソースの方が新しいファイルをターゲットフォルダにコピーします。
同期 新規作成ファイルと更新日時の新しいファイルをコピー、ソースにないファイルを削除します
  • バックアップモードでの処理に加えて、ターゲットフォルダにあるファイルでソースに存在しないファイルを削除します。
双方向バックアップ ソースとターゲットの間で双方向にバックアップを行います
  • バックアップモードでソースとターゲットの間で双方向に処理を行います。
  • 処理元とターゲットフォルダそれぞれに存在しないファイルを補い合います。さらに、処理元とターゲットの両方に存在するファイルは新しいファイルを反対方向へコピーします。
コピーバックアップ すべてのファイルをコピーします。アーカイブ属性の変更は行いません
  • すべてのファイルがコピー対象になります。
  • コピー処理後にファイルのアーカイブ属性をオフにしない点がフルバックアップとは異なります。
フルバックアップ すべてのファイルをコピーします。コピー後にアーカイブ属性をオフにします
  • すべてのファイルがコピー対象になります。
  • コピー処理後にファイルのアーカイブ属性をオフにします。
差分バックアップ アーカイブ属性ファイルをコピーします。アーカイブ属性の変更は行いません
  • アーカイブ属性がセットされたファイルだけがコピー対象になります。コピー処理後にアーカイブ属性をオフにしません。
  • 更新日時の比較なしに、アーカイブ属性の有無でコピー対象を決定しますので高速にバックアップすることができます。
  • 通常、新規ファイルとファイルの中身を修正したタイミングでアーカイブ属性がOSによりセットされます。ファイルの属性についてはエクスプローラからプロパティで確認修正できます。
増分バックアップ アーカイブ属性ファイルをコピーします。コピー後にアーカイブ属性をオフにします
  • アーカイブ属性がセットされたファイルだけがコピー対象になります。コピー処理後にアーカイブ属性をオフにします。
  • 増分バックアップは、直前の「フルバックアップ」または「増分バックアップ」から変更されたファイルだけをバックアップすることができる。
ファイル更新 ターゲットに存在するファイルの中で更新日時の新しいファイルだけをコピーします
  • ソースとターゲットの両方に存在するファイルでソースの方が新しいファイルをターゲットフォルダにコピーします。
復元 ターゲットに存在しないファイルと古いファイルをコピーします
  • ターゲットフォルダに存在しないソースにだけ存在するファイルとソースとターゲットの両方に存在するファイルでソースの方が古いファイルをターゲットフォルダにコピーします。
ファイル比較 プレビューウインドウを開きソースとターゲットに存在するすべてのファイルを比較します
  • ソースとターゲットに存在するすべてファイルのプレビューウインドウに表示します。その後、自動的にファイルの比較まで実行します。


プロジェクトファイルについて

  • バージョン３以降、プロジェクトファイル(.CP2)の内部形式が変更となりました。

■プロジェクトファイルとは

  • 処理対象となるフォルダ、処理モード、プロパティ設定内容をプロジェクトファイルに保存します。
  • 「CopyToプロジェクト」ファイルはWindowsに関連づけられているのでダブルクリックなどで開くことにより、ショートカットと同じようにすぐに処理がはじまります。
  • プロジェクトファイルの拡張子は「cp2」でファイルの種類は「CopyToプロジェクト」になります。
  • エクスプローラなどで「CopyToプロジェクト」ファイルを選択し、右クリックで表示されるメニューから「」を選択することでオプション修正が簡単にできます。

■CopyTo Synchronizerからの操作

  • [メイン]-[プロジェクト]　タブにて保存、読込を行います。
  • 読み込み後、プロパティ画面などで各種設定を変更し、もう一度「保存」を行うことで設定内容の修正が可能です。

■エクスプローラのコンテキストメニューからの操作

エクスプローラなどでプロジェクトファイルを選択後、コンテキストメニューから次の操作が直接可能です。

  • プロジェクトファイルのフォルダ設定
    [メイン]-[複数ファイルとフォルダの設定]が開きます。修正後保存することができます。
  • プロジェクトファイルのプロパティ
    [メイン]-[プロパティ]が開きます。修正後保存することができます。
  • プロジェクトファイルの実行履歴
    プロジェクトの過去の実行履歴を開きます。
  • プロジェクトファイルの読込
    プロジェクトファイルを読み込み、CopyTo Synchronizerを起動します。


HOWTO/FAQ

  • 定期的なスケジュール実行
    タスクを利用したスケジュール実行を参照して下さい。
  • エクスプローラをシェル拡張し、コンテキストメニューからCopyToを起動する
    [メイン]-[全般]タブ-[詳細]設定-[エクスプローラ シェル拡張]タブを参照して下さい。
  • 各処理のタイミングで指定したサウンドファイル(WAVE)を再生します。
    [メイン]-[全般]タブ-[詳細]設定-[サウンド]タブを参照して下さい。
  • エクスプローラでプロジェクトファイルの拡張子(.cp2)を表示しない
    [メイン]-[全般]タブ-[詳細]設定-[その他]タブを参照して下さい。
  • 起動時にCopyTo Synchronizer を画面の中央に表示する
    [メイン]-[全般]タブ-[詳細]設定-[その他]タブを参照して下さい。
  • ネットワークフォルダを指定するには
    [メイン]画面
    [メイン]-[複数ファイルとフォルダの設定]
    [メイン]-[プロパティ]-[ネットワーク認証]タブを参照して下さい。
  • フォルダ指定のリストボックスなどの履歴を削除したい
    [メイン]-[全般]タブ-「履歴の整理」を参照して下さい。

■よくある質問

  1. プログラムの表示フォントや大きさを変更するには
    プログラムで使用されるフォントはエクスプローラと同様にデスクトップのアイコンと同じものが使用されます。次のファイルにて個別に指定することもできます。通常、次の場所にあります。
    C:\Program Files\CopyTo\Languages\Japanese.lng

  2. タスクが実行されず、状態に「タスクスケジューラ セキュリティデータベースに、指定されたタスクのアカウント情報がありません」と表示される
    Windows 98/Meではパスワードを指定せずにタスクを実行できましたが、Windows XP ではセキュリティの強化のため、パスワードを設定していないタスクをスケジュール起動できないように変更されました。該当するタスクのプロパティを開きパスワードを設定してください。
    Windows XP SP2では、タスクのプロパティを開き、「ログオンしている場合にのみ実行する」をオンにすると、タスクを現在ログオンしているユーザーで実行することができます。

  3. ファイルシステムによるファイル更新日時の違い
    WindowsではOSやファイルシステムによりファイルの更新日時の保持方法が異なり、それらの間でコピーしたときに更新日時が変化することがあります。本プログラムではこれらの時間差を自動で調整します。

  4. Windows98/Me/NT4でV2.6からバージョンアップしたときプロジェクトファイルのアイコンが古いままとなる
    Windowsのアイコンを一時記憶しているキャッシュファイルを再作成することで新しいアイコンになります。手順はこちらを参考にして下さい。
    http://support.microsoft.com/default.aspx?scid=kb;ja;133733

  5. 更新時に処理元とターゲットで、あるファイルの更新日時が同じにもかかわらず、更新対象になることがある
    [コントロールパネル] - [地域]プロパティの[地域]タブの内容が正しく設定されているかを確認します。ネットワーク経由で接続しているならば、両方のコンピュータで行って下さい。


タスクを利用したスケジュール実行

※「タスクコントローラー」はVista以降のOSではサポートされません。

■プロジェクトのスケジュール実行をサポートする「タスクコントローラ」

「スタートメニュー」のプログラムフォルダに「タスクコントローラ」アイコンが作成されています。このプログラムはWindows標準のタスクが持つ機能に加えて、CopyToプロジェクトのフォルダ設定やプロパティなどを直接修正することも可能としています。

  • 実際のスケジュール処理はWindowsのタスクが行います。したがって、このプログラムが起動していなくともスケジュールは実行されます。
  • プロジェクトファイルの追加に便利な機能を実装しています。
  • プロジェクトファイルのプロパティ（設定）変更、フォルダ設定の変更、実行履歴の参照が可能です。
  • 他のアプリケーションの実行に負担をかけないでCopyToを実行するには「実行優先度の設定」が「低」の状態にしたプロジェクトファイルを実行すると効果的です。
  • CopyToの動作を意識しないでバックグラウンドで実行させるには、プレビューウインドウを表示しない設定や進行状況ダイアログを表示しない設定にすると効果的です。

タスクが実行されず、状態に「タスクスケジューラ セキュリティデータベースに、指定されたタスクのアカウント情報がありません」と表示されるときは…


インストールとアンインストール/動作環境

  • バージョン2.7以降、プログラムのインストールフォルダを指定できるようになりました。
  • CopyToプロジェクトファイルはそのまま新バージョンで使用できます。

■サポートするプラットホーム

  • Windows 98/Me（Ver3以降、Windows95はサポート外となりました）
  • Windows NT 4.0, Service Pack 3 以降（ただし、「タスクコントローラ」は動作しません）
  • Windows 2000 Professional
  • Windows XP Home, Professional
  • Windows Vista （Ultimate 32-bit Versionで動作確認しています）
  • Windows 7 （x86/x64版(64bit版)で動作することを確認しています）
  • それぞれ日本語版とUS版で動作確認しています。

■サポートするファイルシステム

CopyTo Synchronizerが処理可能なファイルシステムはエクスプローラでアクセス可能となっているものです。したがって、CD-R/RWドライブなどに書き込むにはパケットライティング・ソフトウェアが必要となります。

■インストール方法

  • Windows2000/XP/NT4.0でのインストールには管理者権限が必要です。
  • 配布された自己解凍形式のファイルを実行し、後は画面の指示に従ってください。インストールが正常に終わるとスタートメニューのプログラムの中の[CopyTo Synchronizer]フォルダに[CopyTo Synchronizer]プログラムとヘルプ・ファイルが登録されます。

■アップデート(バージョンアップ)方法

  • 以前のバージョンをアンインストールせず、そのまま最新版のセットアップを実行して下さい。セットアップ先のフォルダは以前と同じフォルダを指定して下さい。
  • 旧バージョンのプログラムファイルは自動的に削除されます。

■アンインストール方法

  1. Windowsの [スタート]-[設定]-[コントロールパネル] メニューを選択します。
  2. [アプリケーションの登録と削除]を起動します。
  3. [CopyTo Synchronizer]を選択し、[追加と削除]ボタンを押します。
  • 環境によってはアンインストール実行後にWindowsの再起動を要求されることがあります。
  • アンインストールを実行したときにエラーが発生した場合は、もう一度インストールしてからアンインストールを行って下さい。何らかの要因でアンインストールプログラムが削除されていることが考えられます。


プレビューウィンドウへ登録するアプリケーション

プレビューウィンドウではコンテキスト(右クリック)メニューへアプリケーションを登録することができます。選択している処理元とターゲットのファイル名をオプションとしてアプリケーションを起動することができます。コマンドラインオプションをサポートしたファイル比較ツールなどを登録することを想定しています。

  • CSDiff (File difference analysis tool)

おすすめのテキストファイル比較ツールです。色分けや打ち消し線でファイルの相違を分かり易く表示します。英語版のソフトですが、表示フォントを選択できますので相違の表示を日本語で行うことができます。入手先は
http://www.componentsoftware.com/Products/CSDiff/ です。

「実行するアプリケーション」に
「<インストールフォルダ>\Csdiff.exe "%1" "%2"」と指定すればOKです。

  • Windiff
    Windows 2000のCD-ROMの「Support\Tools」フォルダ、Windows98のCD-ROMの中の￥Tools￥Reskit\file、Microsoftの言語製品に付属しています。


コマンドライン オプション

  • オプション指定では大文字と小文字を区別しません。

■CopyToプロジェクトの実行

copyto.exe /exec ＜プロジェクトファイル１＞ ＜プロジェクトファイル２＞...＜プロジェクトファイルｎ＞

■CopyToプロジェクトの読込

copyto.exe /edit ＜プロジェクトファイル＞


[メイン]画面

項目名 　 処理内容
ソース
  • 処理元となるソースのフォルダやファイルを指定します。
  • ネットワーク上の共有フォルダはUNC形式で指定できます(\\<サーバー名>\<共有名>）。<サーバー名> にはサーバー名、<共有名> には共有リソースの名前を指定。
  • 参照ボタンを押すとフォルダを一覧から選択することができます。
  • 「複数フォルダの設定」画面を利用して入力修正することができます。
ターゲット
  • 処理先となるターゲットのフォルダを指定します。
  • 存在しないフォルダが指定されたときは処理時に新しくフォルダが作成されます。
モード
  • ドロップダウンリストから処理モードを選択します。
複数フォルダの設定
  • 「複数フォルダの設定」画面を表示します。
ソースとターゲットの入れ替え
  • ソースとターゲットの入力内容を入れ替えます。
プロパティ
  • 現在プログラムに読み込まれているプロジェクトファイルのプロパティ（設定内容）画面を開きます。
プレビューチェックボックス
  • プレビューウインドウを表示するかどうかが表示され、ここでも変更することができます。
OK
  • 現在プログラムに読み込まれている設定内容で処理を実行します。
  • 処理が終了するとプログラムも終了します。
適用
  • 現在プログラムに読み込まれている設定内容で処理を実行します。
  • [適用]ボタンを押したときは、処理実行後にプログラムが終了しません。
閉じる
  • プログラムを終了します。


[メイン]-[複数ファイルとフォルダの設定]

項目名 　 処理内容
ソース
  • 処理元となるソースのフォルダやファイルを指定します。
  • 参照ボタンを押すとフォルダを一覧から選択することができます。
  • をクリックすると置換マクロを挿入することができます。 処理実行時に以下のように置換されます。このマクロをフォルダ名に指定することにより、日付別のフォルダにバックアップすることもできます。

    %LABEL=XXXX%：ボリュームラベル[XXXX]に一致するドライブ文字
    （USB接続機器などドライブ名が変化するときに有効です。処理時に指定されたラベルを持つドライブを探します）
    %Date%：年月日
    %Time%：時分
    %Year%：年
    %Month%：月
    %MonthName%：月の名前
    %Day%：日
    %DayOfWeek%：曜日
    %Hour%：時
    %Minute%：分
    %Second%：秒

  • をクリックすると指定フォルダを開きます。
ターゲット
  • 処理先となるターゲットのフォルダを指定します。
  • 参照ボタンを押すとフォルダを一覧から選択することができます。
  • をクリックすると指定フォルダを開きます。
  • をクリックすると置換マクロを挿入することができます。
  • 存在しないフォルダが指定されたときは処理時に新しくフォルダが作成されます。
上へ
  • 選択した行を上へ移動します。
下へ
  • 選択した行を下へ移動します。
追加
  • 入力行を１行追加します。ソースとターゲットのリストビュー内でダブルクリックしても同様です。
削除
  • 選択した行を削除します。
ターゲット自動設定
  • 選択したフォルダの配下にソースフォルダ名を元としたターゲットフォルダを自動設定します。

例、表１の状態のとき、「ターゲット自動設定」ボタンを押し、「E:\backup」フォルダを選択すると表２ようにターゲットが設定されます。

表１
ソース | ターゲット
D:\Data\Favorites |
D:\Home\installer |
D:\Program Files\vhd |

表２
ソース | ターゲット
D:\Data\Favorites | E:\backup\Favorites
D:\Home\installer | E:\backup\installer
D:\Program Files\vhd | E:\backup\vhd
パス名の一括置換
  • 入力されているソース、またはターゲットのパス名を対象として検索し、該当する部分をすべて置き換えます。
ソースとターゲットの入れ替え
  • ソースとターゲットの入力内容を入れ替えます。
OK
  • 内容を保持し、画面を閉じます。
キャンセル
  • 内容を破棄し、画面を閉じます。


[メイン]-[プロパティ]

  • プロジェクトプロパティ画面で設定した内容は、プロジェクトファイルに保存することができます。
  • プロジェクトファイルは再度読込んで再利用することができます。
  • プロジェクトプロパティ画面で何らかの設定を変更し、「閉じる」ボタンを押したとき、プロジェクトファイルへ保存していないときは[プロジェクト]タブに切り替わり ます。これはプロジェクトファイルへの保存を促すためです。必要がなければ「閉じる」ボタンを押して下さい。

全般

  • [現在の設定を標準にする]をチェックし「OK」ボタンを押すと、現在の設定内容が保存され、次回、CopyToを起動したときの標準の設定となります。ただし、プロジェクトファイルから起動した場合は除きます。

項目名 処理内容
処理対象
サブフォルダを含む
  • サブフォルダも処理対象とします。
隠し属性のフォルダを除く
  • 隠し属性のフォルダを処理対象から除きます。
システムと隠し属性ファイルを除く
  • システムと隠し属性のファイルを処理対象から除きます。
使用中のファイルを処理対象から除く
  • 他のアプリケーションで使用中のファイルを処理対象から除きます。
処理対象となるファイルがないときフォルダを作成しない（空のフォルダは作成されない）
  • 処理対象となるファイルがないフォルダを作成しません（空のフォルダは作成されない）
ごみ箱
削除でごみ箱へ移動
  • ファイルを削除するときごみ箱に移動します。チェックしなければ直接削除します。
置換する前に元のファイルをごみ箱へ移動する
  • 置換するときに上書きせずに元のファイルをごみ箱へ移動し、そのあとにコピーします。これにより、置換したファイルもごみ箱から戻すことが可能になります。
プレビューウインドウ
処理前にプレビューウインドウを表示する
  • 処理前にすべての処理内容を表示する「プレビューウインドウ」を表示します。このオプションを選択しているときは、更新状況の調査ダイアログのチェックボックスをオフにすることで、「プレビューウインドウ」をスキップすることができます。
すべてのファイルを表示
  • プレビューウインドウに更新日時の一致するファイルも表示します。これらのファイルはプレビューウィンドウの初期状態ではチェックマークは付きません。このオプションにより、処理元とターゲットの間で更新日時の一致するファイルもバイナリモードで比較することなどが可能になります。
プレビューウインドウを表示するときすべて省略して表示する
  • 「プレビューウインドウ」を表示するときすべてのフォルダを折りたたんで表示します。
各種メッセージ
進行状況ダイアログを表示する
  • 進行状況ダイアログを表示します
ファイル単位にコピー進捗状況を表示する
  • ファイル単位にコピー進捗状況を表示します
  • このオプションをオフにするとバージョン２と互換性のある方法でコピー処理を行います。
  • Windows9X系では無効です。
処理終了後、進行状況ダイアログボックスを閉じる
  • 処理終了後、進行状況ダイアログボックスを閉じます。
空き容量が足りないときに警告する
  • 処理前にすべての処理を終えるにはディスクの容量が足りないと思われるときに警告のダイアログを表示します。フォルダを作成することに必要な容量は含まれていません。
処理すべきファイルがないときメッセージを表示する
  • 処理すべきファイルがないときに確認ダイアログボックスを表示します。
プロジェクトファイルを実行する前に確認する
  • プロジェクトファイルをダブルクリックなどにより実行するとき、処理をスタートする前に確認ダイアログを表示します。
ファイルを上書きする前に確認する
  • 複数のファイルを上書きするときには以降のファイルを全て上書きする選択ができます。プレビューウインドウを表示しない設定にしているときに有効です。
ファイルを削除する前に確認する
  • 複数のファイルを削除するときには以降のファイルを全て削除する選択ができます。プレビューウインドウを表示しない設定にしているときに有効です。
コピーと削除でエラーが起きたときメッセージを表示しない
  • コピーと削除でエラーが起きたとき、メッセージを表示しないで処理を続けます。ログを参照するとエラーが起きたかどうかを確認できます。このオプションをオフにしたときはエラーの内容を画面に表示して、もう一度行うか、スキップするかの選択ができます。
エラーが発生したとき、処理終了後にログを表示する
  • エラーが発生したとき、処理終了後にログファイルを関連付けられたアプリケーションで表示します。ログを保存しているときのみ有効です。
その他
コピー後、コピー元と比較し、正しく書かれたどうかを検証する(ベリファイ)する
  • ファイルをコピーした後に、コピー元のファイルとターゲットとのファイルをバイナリ比較します。処理スピードは遅くなりますが、重要なファイルのときはONにした方がよいかもしれません。ログにも結果が保存されます。バイナリ比較した結果が一致しないときは確認ダイアログが表示され、もう一度コピーする選択ができます。
コピー後、コピーしたファイルの読みとり属性をオフにする
  • ファイルをコピーした後に、コピー先ファイルの読み取り属性をオフにします。CD-ROMなどから処理するときに有効です。(フォルダ圧縮時は無効)
コピー後、コピーしたファイルのNTFS圧縮属性をオンにする
  • ファイルをコピーした後に、コピー先ファイルのNTFS圧縮属性をオンにします。(NTFSドライブでのみ有効)
コピー後、コピーしたファイルの暗号化属性をオフにする
  • ファイルをコピーした後に、コピー先ファイルの暗号化属性をオフにします。(NTFSドライブでのみ有効)
Treats files exactly 1 hour apart as equal for daylight savings time
  • このオプションは夏時間に対応するために用意されています。夏時間のない日本で使用するときは、ONにする必要はありません。


フィルター

  • [現在の設定を標準にする]をチェックし「OK」ボタンを押すと、現在の設定内容が保存され、次回、CopyToを起動したときの標準の設定となります。ただし、プロジェクトファイルから起動した場合は除きます。

■対象ファイルの指定

処理対象となるファイル、または対象から除くファイルの名前を指定します。「編集」ボタンを押すと [ファイル指定の編集]画面で簡単に追加、修正、削除が行えます。

項目名 | 処理内容
すべてのファイル | すべてのファイルを処理対象とします。
指定ファイルだけ | 指定したファイル名に一致するファイルだけを処理対象とします。
指定ファイルを除く | 指定したファイル名に一致するファイル以外を処理対象とします。

例　abc*.bak;*.tmp

  • 複数指定する場合は空白をあけないで「 ; 」セミコロンで区切ります。
  • ワイルドカード(?,*)が指定できます。「?」には任意の１文字だけが該当し、「*」は任意の複数文字が該当します。

■指定フォルダとファイルを除く

特定のフォルダやファイルを処理対象から除きたいときにチェックします。チェックすると「選択」ボタンが有効になります。これを押すとウインドウが表示されますので、ここに、フォルダやファイルを指定します。ワイルドカード(?,*)での指定が可能です。エクスプローラからフォルダやファイルをドラッグしても追加 可能です。

項目名 処理内容
フォルダ追加
  • フォルダの一覧から参照して入力します。
  • パス名をつけないでフォルダ名だけ指定したときはそのフォルダ名を持つフォルダすべてを処理対象から除きます。この指定をするには[編集]ボタンを押し、パス部分を削除して下さい。
ファイル追加
  • ファイルを参照して入力します。一度に複数のファイルを選択することができます。
編集
  • リストボックスで選択している項目を修正することができます。[F2]キーを押しても可能です。
削除
  • リストボックスで選択している項目を削除します。

  • フォルダの場合はサブフォルダも含めて除かれます。
  • 指定可能なフォルダとファイル数の上限は合わせて、1024個までです。


対象期間

  • 処理対象とするファイルを更新日時で絞り込みます。

■日付指定

処理対象とするファイルの更新日時を絶対期間で指定します。

■相対期間

処理対象とするファイルの更新日時を相対期間で指定します。処理を実行したときの時刻で期間を計算します。


世代管理

  • ソースの新しいファイルでターゲットファイルを置換する前にターゲットファイルを次の規則で名前を変更します。これにより古いファイルを数世代にわたり保存していくことができます。
  • 差分・増分バックアップ時は本機能は使用できません。

■ファイル名にファイルの更新日時を付加

  • 古いファイルの名前にファイルの更新日時を付けて保存して行きます。同名のファイルが存在するときは古いファイルは削除されます。

■ファイル名に数字を付加

  • 保存する最大数を指定します(最大 : 999)。 9と指定したときは1～9、10と指定したときは01～10、999と指定したときは001～999が付加されます。
  • リネーム後のファイルが存在するときは「保存する最大数」まで数字部をカウントアップしていきます。
  • 「保存する最大数」を超えたファイルは削除され、「保存する最大数」だけ最新のファイルが残ります。


フォルダ圧縮の機能について

  • [圧縮]機能をオンとしたとき、フォルダの中に実際に存在するファイルの代わりにZIP圧縮ファイルの中に格納されているファイルを対象として処理します。
  • この結果、ターゲットをフォルダ圧縮指定としたとき、処理元からコピーされるファイルはターゲットフォルダの中の圧縮ファイルに格納されます。逆に、ソースがフォルダ圧縮指定ならば、ソースフォルダにある圧縮ファイルからターゲットフォルダに展開されます。
  • 圧縮ファイル名は任意に指定可能で、処理時に同名のファイルが存在する場合は元のファイルを数字やファイルの更新日時を付加したファイル名で世代管理していくことが可能です。
  • フォルダ圧縮時、プレビューウインドウのステータスバーに表示される処理量の総計はファイルの圧縮率を 50％として計算しています。
  • ZIP圧縮ファイルはUnicode形式でファイル名を格納できないため、Unicode形式ファイルを処理することができません。

■フォルダ内のファイルの代わりに圧縮ファイルを対象とする

  • このオプションをチェックすると [フォルダ圧縮]が有効になります。「処理元」タブと「ターゲット」タブそれぞれで指定します。

■圧縮ファイル名

  • 任意の圧縮ファイル名を指定します。もし、フォルダ内にここで指定された名前のファイルと同名の圧縮ファイルがあった場合にはそのファイルを対象にして処理が行われてしまうので注意が必要です。
  • 圧縮ファイル名には通常存在することのないユニークなものを使用して下さい。

■パスワードを追加

  • 任意のパスワードを指定します。このオプションを指定したとき展開時にパスワードが必要となります。

■圧縮ファイル名に更新日時を付加

  • 古いファイルの名前にファイルの更新日時を付けて保存して行きます。同名のファイルが存在するときは古いファイルは削除されます。

■ファイル名に数字を付加

  • 保存する最大数を指定します(最大 : 999)。 9と指定したときは1～9、10と指定したときは01～10、999と指定したときは001～999が付加されます。
  • リネーム後のファイルが存在するときは「保存する最大数」まで数字部をカウントアップしていきます。
  • 「保存する最大数」を超えたファイルは削除され、「保存する最大数」だけ最新のファイルが残ります。


ネットワーク認証

  • ソースまたはターゲットフォルダがUNCパスで指定されたときネットワークの接続を行ってから処理を行います。


ボリュームラベル

  • 処理を行う前にドライブのボリュームラベルを照合し、異なる場合は警告を表示します。
  • ソースとターゲットで照合したいドライブだけをチェックします。
  • MOやZIPなどリムーバルメディアへのバックアップの際にメディアの入れ間違いを防止するのが目的です。

■ドライブのボリュームラベル

ドライブのボリュームラベルを入力します。大文字と小文字は区別しません。

■取得ボタン

現在のドライブのボリュームラベルを調べて自動で入力されます。

■変更ボタン

ドライブのプロパティが開きますので、ボリュームラベルを変更することができます。


他プログラムの起動

  • CopyToの処理開始前、または終了時に起動するショートカット、プログラムやバッチファイルなどのプログラムを指定します。
  • 指定したプログラムの終了を待ってから処理を続けます。

■マクロボタン

メニューから選択して入力します。マクロ部分は実行時に次の内容に置き換えられます。

マクロ名 | 実行時に置換される内容
%ProjectFullPath% | プロジェクトファイルのフルパス
%ProjectFilePath% | プロジェクトファイル名
%LogFileFullPath% | ログファイルのフルパス
%LogFileName% | ログファイル名


ログ

  • 処理内容をファイルに保存します。

■ファイルサイズの制限をする

ログファイルの大きさを指定するサイズに制限します。単位はKB(キロバイト)です。

■エラーのみログを保存する

正常な処理のログは保存せずに、エラーのみログを保存します。

■ログの形式

ログのファイル形式をHTML形式(タグ使用)、テキスト(タブ区切り)、CSV形式(カンマ区切り)、MS-DOSバッチ形式の中から選択します。

■保存フォルダ

ログを保存するフォルダを指定します。すべてのログファイルはこのフォルダに作成、保存されます。

■プロジェクト名のファイルにログを保存する

プロジェクトファイルから起動したときにはプロジェクトファイル名の拡張子をTXTまたはCSVに変えたファイルにログを保存します。

■ファイル名

ログファイルの名前を指定します。ただし、 [プロジェクト名のファイルにログを保存する]がチェックされているときはプロジェクトファイル名が優先されます。

■ログファイル名に日時を付加する

ログファイル名に選択した年月日形式で処理日時を付加します。


実行優先度

  • 処理実行時のプロセス優先度を指定します。

項目名 | 処理内容
高 | [通常]より高い優先度で実行します。
通常以上 | [通常]より高く、[高]より低い優先度で実行します。
通常 | 通常の優先度で実行します。一般的なアプリケーションの場合、特に指定しない限り、通常の優先度で実行されます。
通常以下 | [通常]より低く、[低]より高い優先度で実行します。
低 | システムがアイドル状態の時のみ実行される優先度で実行します。前面で動作するアプリケーションに負荷をかけたくないときに指定します。


実行履歴

  • 本プロジェクトの過去の実行履歴を表示します。
  • 各行をダブルクリックするとログファイルが存在すれば、そのログを開きます。
  • ログプロパティで「ログファイル名に日時を付加する」を選択することで、処理単位にログファイルを分けることが可能です。


コピー/移動/削除のオプション

  • この画面は処理モードにコピー/移動/削除を選択したときのみ表示されます。
  • モードで上書き/削除の確認ダイアログを表示

■コピー/移動/削除モードで上書き/削除の確認ダイアログを表示

「コピー」「移動」「削除」モードのとき、既存ファイルの上書きと削除をする前に確認のダイアログが表示されます。

■進行状況ダイアログを表示する

処理の進行状況のダイアログを表示します。チェックしていないときは画面に処理をキャンセルするボタンが表示されませんので処理途中でキャンセルすることができません。


[メイン]-[プロジェクト]

  • 処理対象となるフォルダ、処理モード、プロパティ設定内容をプロジェクトファイルに保存します。

■プロジェクト名

作成するプロジェクトファイル名を入力します。「自動」ボタンを押すとソース名と処理モードを組み合わせた文字列が入力されます。

■保存フォルダ

プロジェクトファイルを保存するフォルダを入力します。▼ボタンを押して表示されるリストの中のデスクトップやマイドキュメントなどのフォルダを選択することができます。

■プロジェクトファイルの読込

プロジェクトファイルを読み込み、その内容を「CopyTo」に反映します。▼ボタンを押すと最近使用したものからがメニュー表示されますので、この中から選択することもできます。

■プロジェクトファイルの保存

現在のフォルダ名、処理モード、プロパティ設定内容をプロジェクトファイルに保存します。

■タスクへの登録

現在、使用中のプロジェクトファイルをWindows標準のタスクへ登録します。ボタンを押すとタスクのプロパティ画面が表示されますので以下の設定をして下さい。

  • 実行するアカウントのパスワードを「パスワードの設定」ボタンを押し設定する。
  • スケジュールタブに切り替え、実行スケジュールを設定する。

その後、タスクの各種設定変更はタスクコントローラ、またはエクスプローラのタスクから行うことができます。


[メイン]-[全般]

■タスクコントローラ

タスクコントローラを開きます。

■[詳細]ボタン

詳細設定画面を開きます。

■[ヘルプ]ボタン

ヘルプファイルを開きます。

■履歴の整理

履歴の整理画面を開きます。「ソース」「ターゲット」「対象ファイル」「設定ファイル」「保存フォルダ」それぞれの履歴で不要なものを削除したり、順序の入れ替え、よく使うフォルダを登録することができます。
よく使うフォルダに設定するには履歴リストでそのフォルダをチェックします。チェックした項目は履歴リストの先頭に表示され、新しい履歴が追加されてもリストから消えることはありません。 [履歴の表示数]はチェックされた項目を除いた履歴リストの最大表示数となります。チェック項目の上限は64個です。


[メイン]-[全般]タブ-[詳細]設定

[エクスプローラ シェル拡張]タブ

■コンテキストメニューにCopyToを追加する

エクスプローラのコンテキスト(右クリック)メニューに"Copy to..."を追加するかどうかを指定します。

■標準ボタン

このボタンを押すと標準の設定に戻ります。

■CopyToタイトル

コンテキストメニューに表示するタイトルを指定します。「&」を付けるとその次の文字がショートカットキーになります。

■機能をサブメニューに追加する

コンテキストメニューにサブメニューを追加してその中に「CopyTo」の機能メニューを追加します。

[サウンド]タブ

  • 各タイミングで指定したサウンドファイル(WAVE)を再生します。

[その他]タブ

■エクスプローラでプロジェクトファイルの拡張子(.cp2)を表示する

エクスプローラのフォルダオプションで「拡張子を表示する」にしている場合にも、デスクトップなどのファイル名の表示でプロジェクトファイルの拡張子(.cp2)を隠すことが可能になります。この設定の変更を有効にするには再ログインする必要があります。

■起動時にCopyTo Synchronizer を画面の中央に表示する

起動時にメインウインドウを画面の中央に表示します。チェックされていないときは前回の終了時点の位置に表示します。

■プロジェクト実行履歴の保存数

プロジェクトの実行履歴プロパティに表示される実行履歴の最大数を指定します。


[プレビューウィンドウ]

  • 「プレビューウインドウ」で表示された処理の中でチェックされたものだけが処理されます。
  • 処理内容、ファイル名、更新日時、ファイルサイズなどのタイトル行でクリックすると各項目の内容でフォルダ単位でソートされます。
  • ステータス行に現在チェックされている各処理別のファイルサイズの合計とソースとターゲットに必要な容量の概算が表示されます。
  • 「プレビューウインドウ」の表示フォントはエクスプローラと同様にデスクトップのアイコンと同じものが使用されます。[コントロールパネル] - [画面のプロパティ] - [デザイン]で変更することができます。また、こちらで変更することもできます。
  • 「プレビューウインドウ」では、ほとんどの機能をコンテキスト(右クリック)メニューから実行することができます。(キーボードから行うには[Shift]+[F10]または[Alt]+[A])　また、ツールボタンから実行できる機能もあります。
  • Windows95/98では「プレビューウインドウ」に表示できる行数の上限は32736個です。これを越えたファイルは処理対象外になり、このとき警告メッセージが表示されます。ただし、「プレビューウインドウ」を表示しない場合は制限がありません。また、WindowsNT/2000/XPではこの制限はありません。

■処理別アイコン一覧

処理 | 処理内容
 | フォルダを作成
 | フォルダを削除
 | ソースの新規ファイルをターゲットフォルダにコピー
 | ターゲットの新規ファイルを処理元フォルダにコピー
 | ソースのファイルをターゲットフォルダにコピー
 | ターゲットのファイルを処理元フォルダにコピー
 | ファイルを削除

■コンテキスト(右クリック)メニューの機能

処理

   処理内容
[チェック]/[チェックオフ] | 変更したいファイルやフォルダを選んで「チェック」「チェックオフ」を選びます。チェックボックスのクリック、その行のダブルクリック、スペースキーを押しても可能です。フォルダ行 [image] を選んだときはフォルダ内のすべてが対象となります。
[処理方向を逆に/追加<->削除] ファイル単位で処理する向きを逆にします。フォルダ行 [image] を選んだときはフォルダ内のすべてが対象となります。
  更新ファイル：コピーする向きを「処理元」と「ターゲット」の間で逆にします。
  追加ファイル：反対側に追加する状態になっているファイルを削除するように処理を変更します。
  削除ファイル：削除しないで反対側に追加するように処理を変更します。
[処理方向の設定] | 選択しているファイルやフォルダの処理方向をまとめて設定します。
[すべて展開]/[すべて省略] | すべてのフォルダを展開、または折りたたんで表示します。
[処理元を開く]/[ターゲットを開く] 　 | 選択しているファイルをWindowsで関連づけられているアプリケーションで開きます。フォルダ行 [image] のときはそのフォルダを開きます。ファイルを他のアプリケーションで開くときなどに使用できます。
[プロパティ] | 選択しているファイルやフォルダのプロパティシートを開きます。
[選択したフォルダ/ファイルを除外リストへ追加]
  • 選択したフォルダ/ファイルをプロジェクトプロパティの「指定フォルダとファイルを除く」へ追加します。
  • プロジェクトファイルを使用しているときには同時にプロジェクトファイルの保存も行います。
[ツール] 　 | サブメニュー「ツール」を表示します。
[すべて選択] 　 | すべてのファイルを選択します。
[現在のフォルダ内をすべて選択] 　 | 選択されているフォルダ内に含まれるすべてのフォルダ(サブディレクトリも含む)、ファイルを選択状態とします。
[選択の切り替え] 　 | 現在の選択状態を反転します。

■コンテキストメニュー[ツール]の機能

処理 | 処理内容
[バイナリで比較] | 選択状態のソースとターゲットのファイルを連続してバイナリモードで比較します。処理終了後には不一致のファイルが選択状態となります。更新日時の一致するファイルもバイナリモードで比較したいときは更新オプションで 「プレビューウィンドウですべてのファイルを表示」をONにしておくと、一致するファイルも表示されます。ただし、これらのファイルはプレビューウィンドウの初期状態ではチェックマークは付かないで表示されます。
[選択行をクリップボードへコピー] | 選択状態の行をテキスト(タブ区切り)形式、またはCSV(カンマ区切り)形式でクリップボードへコピーします。テキスト(タブ区切り)形式ではExcelなどのアプリケーションにそのまま張り付けると自動でセルに入力されます。
[選択行をファイルへ保存] | 選択状態の行をCSV形式(カンマ区切り)、またはテキスト(タブ区切り)形式でファイルへ保存します。保存時に拡張子をCSVにすると、CSV形式で保存されます。その他の場合はテキスト(タブ区切り)形式でファイルへ保存します。
[展開/省略] | フォルダ行で実行するとフォルダ内のすべての処理を折りたたんで表示します。もう一度実行すると展開します。 マークをクリック、スペースキーを押しても同様です。
[処理元]/[ターゲット]-[すべての追加]/[すべての更新]/[すべての削除]の処理の変更 | いろいろな処理モード単位でまとめてチェック/チェックオフ/処理変更をすることができます。
[空き容量の再表示] | 処理元とターゲットの空き容量を再表示します。リムーバルメディアを交換したときなどに使います。
[列幅を自動調整] | 項目の値がすべて見えるように省略することなく表示します。
[常に前面に表示] | プレビューウインドウを常に再前面に表示します。
[オプション...] | プレビューウインドウのオプション設定ダイアログを表示します。


[プレビューウィンドウ]-[オプション]

[表示]タブ

  • プレビューウインドウに表示する項目などを選択します。

[プログラム登録]タブ

  • プレビューウインドウのコンテキストメニューから起動するアプリケーションを登録します。
  • 選択行のソースとターゲットのファイル名をオプションとしてアプリケーションを起動することができます。
  • コマンドラインオプションをサポートしたファイル比較ツールなどを登録することを想定しています。

項目名 | 処理内容
メニュータイトル | コンテキストメニューに表示するタイトルを入力します。
コマンドライン | 実行プログラムとオプションなどを指定します。%1と%2は実行時に各々次のように展開されます。%1と%2は片方だけ指定してもかまいません。 %1 ソースファイル名に置き換えられます。 %2 ターゲットファイル名に置き換えられます。

[色]タブ

  • 文字、圧縮ファイルの文字色と罫線、背景色１、背景色２の変更。標準ボタンでWindowsのシステムカラーに戻ります。背景色１と背景色２を違う色に設定することでストライプ表示が可能になります。

[クリップボード]タブ

  • クリップボードへコピーするときの形式を選択します。テキスト(タブ区切り)か、CSV(カンマ区切り)形式を選択できます。


トラブルシューティング/よくある質問

■トラブルシューティング手順

このソフトウエアで発生する問題のお問い合わせは次の項目を明記して、こちらのフォームから必要な情報を送信して下さい。

  • CopyToのバージョン。
  • OSの詳細なバージョン。98/98SE/2000/XP/Vista/7など。
  • 問題の発生するドライブの種類、ファイルシステムの種類(FAT/FAT32/NTFS)とドライブの容量と空き容量。
  • 問題の発生する操作手順とその詳細な現象、可能ならばそのときのログファイルをメールに添付。
  • 可能ならば、問題が発生するときの設定を保存したcp2ファイル、画面をキャプチャしたファイルをメールに添付。


ライセンスの購入について

  • CopyTo SynchronizerはVer 3.31よりフリーウエアとなりました。


製品情報と最新バージョンの入手方法/著作権

■最新情報と最新バージョンのダウンロードは次のURLにて提供しております。
http://www.kish-d.com/index-j.html

「CopyTo Synchronizer」は、下記条項にご同意いただいた場合にのみご使用いただけます。本ソフトウェアを使用された場合は下記条項にご同意いただけたものとさせていただきますので、下記条項を充分お読みの上ご使用ください。

■ライセンス同意書
未登録のソフトウェアについて
  未登録のソフトウェアは、30日間の試用期間、無料で使用することが出来ます。この期間を過ぎて、継続してご使用される場合は、ライセンスをご購入頂く必要があります。未登録のソフトウェアは、パッケージ内のファイルに一切変更を加えない限り、自由にコピー、再配布することが可能です。Web、FTP、BBSへの転載、雑誌への掲載などを認めます。ただし、事後で結構ですので、連絡して下さい。

登録ソフトウェアについて
  本ソフトウェアにおける使用ライセンスは使用ユーザ単位で数えられるものであり、インストールするパソコンの台数単位ではありません。ご購入のライセンス数を超える数のユーザが使用することは出来ません。逆に、使用ユーザ数がライセンス数を上回らない限り、バックアップまたは、複数台のパソコンにおける使用を目的としたコピーを複数作成することが出来ます。
  ライセンスの購入は、本ソフトウェアの著作権の購入を意味するものではありません。また、購入済みのライセンスについては、いかなる理由をもってしても換金及び返品はできません。なお、登録ソフトウェアのバージョンアップについてはユーザがインターネットサイトまたはその他メディア等より自身の手で入手する必要があります。また、いかなる場合であってもバージョンアップの義務をユーザに対して負うものではありません。作者は、本ソフトウェアに対して不具合の修正や、機能拡張、バージョンアップの通知等の義務を負わないものとします。

登録パスコードについて
  ご登録ユーザの方は、登録パスコードを取得することが出来ます。これは、未登録のソフトウェアにおいて表示される起動時のメッセージボックスを表示させないようにするため必要となるものですが、このパスコードは使用ライセンス自身とは無関係なものです。従って、なんらかの不正な手段、あるいはプログラムロジックの解読などによりこのパスコードを入手し、起動時のメッセージボックスが表示されなくなったとしても、使用ライセンスを入手したことにはなりません。継続使用、または不正な配布を目的としてこのような行為を行った場合、これは違法コピーとみなされ、法的手段による処罰の対象となります。
  ご登録ユーザのみが登録されたライセンスの数に基づいてのみ、このパスコードを使用することが出来ます。

責任の制限
  本ソフトウェア、および付随する著作物は、現状有姿での提供となります。商品性及び、特定の目的への適合性などについての保証を含む、いかなる保証も、それを明記する、しないに関わらず、提供されません。
  この製品の著作者及び、製造、配布に関わるいかなる者も、本ソフトウェアの使用、または使用不能によって発生する損害に対する責任は、それが直接的であるか間接的であるか、必然的であるか偶発的であるかに関わらず、負わないものとします。それは、その損害の可能性について、著作者が事前に知らされていた場合でも同様です。

著作権
  ソフトウェア製品は、著作権法及び国際著作権条約をはじめ、その他の無体財産権に関する法律ならびに条約によって保護されています。ソフトウェア製品は許諾されるもので、販売されるものではありません。
「CopyTo Synchronizer」の著作権は、私、kishにあるものとします。本ソフトウェアに対するリバースエンジニアリング及び、改変は一切禁止します。


バージョン履歴

Ver 3.20 非公開

Ver 3.10 2007.04.15

  • Windows Vistaに正式対応（「タスクコントローラ」の実行には管理者権限が必要です）
  • 置換マクロにてボリュームラベルによるドライブ文字の指定を可能とした。（例、%LABEL=XXXX%）
  • 処理対象フォルダの指定で置換マクロをソースでも有効とした。
  • ファイル処理時に表示されるアニメーションを廃止とした。

Ver 3.09 2006.03.27

  • Windows2000/NTにてファイルのコピー時に「パラメータエラー」となった不具合を修正した。

Ver 3.08 2006.03.25

  • ソースファイルが暗号化属性のとき、ターゲットが暗号化をサポートしないドライブでもコピーされるように修正した。
  • [プロジェクトプロパティ]-[全般]の[その他]に「コピー後、ファイルの暗号化属性をオフにする」オプションを追加した。
  • プレビューウインドウで暗号化属性ファイルに「E」マークを付け、指定色で表示するようにした。

Ver 3.07 2006.02.16

  • 4GBを超えるファイルのサイズがプレビューウインドウで正しく表示されなかった問題を修正した。
  • 「削除でゴミ箱へ移動する」というオプションが保存されないことがあった問題を修正した。
  • プレビューウインドウで選択したフォルダ/ファイルを「指定フォルダとファイルを除く」へ追加することを可能とした。
  • プレビューウインドウでチェックされていない行を淡い色で表示するようにした。
  • 言語ファイルにより多言語対応し、ユーザーインターフェイスの言語を切り替えを可能とした。

Ver 3.05 - 3.06 非公開

Ver 3.04 2005.04.25

  • [複数ファイルとフォルダの設定]画面：ターゲット自動設定機能とパス名の一括置換機能を追加。
  • [メイン]-[全般]タブ-[詳細]画面にてプロジェクト実行履歴の保存数を設定可能とした。
  • プロジェクトの実行履歴プロパティから該当するログファイルを開くことを可能とした。
  • プロジェクトプロパティでZIP圧縮を指定したときパスワードを設定可能とした。
  • UNCパス指定でプロジェクトファイルを開いたときエラーが発生した問題を修正。
  • タスクコントローラを２重起動したとき既に起動しているものをアクティブにするように修正。

Ver 3.03 2005.03.30

  • [プロジェクトプロパティ]-[全般]の[その他]に「ファイル単位にコピー進捗状況を表示する」するかどうかのオプションを追加した。
  • Windows2000/XPの制限ユーザーでインストールしたときの問題を修正。

Ver 3.02 2005.03.18

  • 世代管理バックアップを指定し、ターゲットに圧縮ファイルを指定したとき、ZIP圧縮ファイルで既存ファイルの名前変更に失敗していた問題を修正した。
  • プレビューウインドウで削除ファイルの背景色を設定可能とした。その色はHTML形式ログファイルの背景色としても使われる。
  • プロジェクトプロパティ-全般の「処理終了後にログを表示する」オプションを「エラーが発生したとき、処理終了後にログを表示する」に変更した。

Ver 3.01 2005.03.16

  • プレビューをオフにしたときログが出力されなかった不具合を修正。
  • ログ出力形式をHTML以外としたとき、文字コードをシフトJISとするように仕様を変更。

Ver 3.00 2005.03.08

  • 正式版のリリース

Ver 2.74 2003.06.16

  • プロジェクトファイルを使用したときタイトルバーに名前を表示。（修正で「*」を追加）
  • 次の各タイミングで指定したサウンドファイルを再生する（処理の終了/プレビューウインドウの表示/エラーの発生/確認ダイアログの表示）メイン画面の[全般]タブ内の[詳細]-[サウンド]にて設定する。
  • ログの保存形式に「HTML形式(TABLEタグ使用)」を追加。
  • プレビューウインドウでフォルダ選択時に「現在のフォルダ内をすべて選択」する機能を追加。

Ver 2.73 2003.05.24

  • Windows95/98/Meで、V2.6からバージョンアップしたとき環境によってはプロジェクトファイルのアイコンが古いままになることがあった問題を修正。

Ver 2.72 2003.05.19

  • ファイル処理中に表示されるエラーダイアログの操作性を改良。

Ver 2.71 2003.05.10

  • 不具合修正：指定フォルダの除外設定ダイアログなどで削除キーで項目が削除されていた。

Ver 2.70 2003.03.31

  • インストール時にプログラムのインストールフォルダを指定できるように変更。
  • メイン画面にもプレビュー表示を選択するチェックボックスを用意。
  • 処理元とターゲットの入力ボックスでドロップダウンリストの表示幅を自動調整。
  • 更新処理での不具合修正：処理元、またはソースに指定したフォルダの片方がNTFSドライブのルートであったとき、これに対向するフォルダを作成する際に隠し属性となることがあった不具合を修正した。このフォルダが既に存在したときは問題とならない。
  • 問題が発生した例、
    処理元：NTFSドライブ「C:\」　ターゲット：「D:\BKUP」のとき、「D:\BKUP」が隠し属性となりエクスプローラからこのフォルダが見えなくなっていた。

Ver 2.63 2001.02.12

  • 不具合修正；同一フォルダ内に全角英字で大文字と小文字だけの違いのファイルが存在したとき、これらを同一視するケースがあった。この不具合により、これらのファイルを最初に処理した後、２回目以降も処理対象となる問題などが発生することがあった。

Ver 2.62 2000.11.13

  • 更新状況の調査ダイアログにプレビューするかどうかの表示を追加。

Ver 2.61 2000.09.09

  • プロジェクトファイルの読み込みで、実行優先度が正しく読み込めなかった問題の修正。

Ver 2.60 2000.07.24

  • 実行優先度に「通常以上」「通常以下」を追加、全部で５段階から選択可能になった。
  • [詳細オプション] - [その他]に「起動時にCopyToのウインドウを画面の中央に表示する」を追加。
  • コピーと移動で指定可能な書式を追加。
  • 表記の変更：メイン画面の「キャンセル」を「閉じる」に変更。設定ファイルをプロジェクトファイルに変更。

Ver 2.53 1999/11/06

  • ファイルの更新状況のダイアログに一時停止ボタンを追加。
  • ファイルの更新チェックの開始と終了をログに出力。
  • フォルダ圧縮時に[プレビューウインドウ]でバイナリコンペアを行ったとき圧縮ファイルの展開状況を表示。
  • [圧縮レベル]に圧縮しないでそのまま格納を追加。
  • 不具合修正：[プレビューウインドウ]で項目の幅を小さくしていったときフリーズすることがあった。

Ver 2.51 1999/10/15

  • [プレビューウインドウ]-[オプション]-[色]で第２背景色を設定することにより、プレビューウインドウをストライプ表示する。
  • [更新オプション]-[他プログラムの起動]と[プレビューウインドウ]-[オプション]-[プログラム登録]でEXEとBATに加えてショートカットも設定可能にした。
  • フォルダ圧縮でフォルダ名にシフトJISコードの２バイト目が \(0x5c) の文字が含まれているとき展開エラーが発生した。
  • Windows95/98でプレビューウインドウの表示の上限件数を超えたときフォルダの展開/省略が異常になることがあった。
  • 「Think Different」の名称を「セミオートマティック同期」に変更。

Ver 2.50 1999/09/15

  • 正式リリース版。

Ver 2.27 1999/06/20

  • 実行優先度と終了時に鳴らす音の指定が保存されなくなっていた不具合を修正。

Ver 2.26 1999/06/07

  • 対象ファイル選択で拡張子だけでなくファイル名全体をワイルドカードで指定可能に。
  • 処理対象から除く設定でフォルダ名だけ指定したときその名前のフォルダすべてを処理対象から除く。

Ver 2.25 1999/05/30

  • 処理対象から除く設定でフォルダに加えてファイルも指定可能にした。

Ver 2.24 1999/05/25

  • 「履歴保存」で「数字を付加」を選択しないとき履歴保存できなかった不具合を修正。
  • 「コピーと削除でエラーが起きたときメッセージを表示しない」オプションを追加。

Ver 2.23 1999/04/26

  • 「履歴保存」で「ファイル名に数字を付加」を行ったときに発生する不具合を修正。

Ver 2.21 1999/04/24

  • 更新時アプリケーションタイトルに処理の進行状況を表示する。
  • 複数フォルダの設定ウインドウで最小サイズを制限した。
  • 実行した設定ファイル名をログに出力する。
  • プレビューウインドウのステータス行の表示で処理量の合計が2GBを越えたときも正しく表示されるように修正。

Ver2.2 1999/4/4

  • 正式リリース版。

Ver2.14 1998/12/10

  • 処理元とターゲットのフォルダをUNCパスで指定すると、そのフォルダが存在しなかったときは自動でネットワーク接続を試みます。
  • プレビューウインドウでディスクの空き容量が表示されていなかった不具合などを修正。

Ver2.13 1998/12/3

  • 更新時に「ファイルシステムエラー(1026)」で処理が中止されてしまうことがあったバグを修正。
  • 夏時間を設定している環境で春秋の夏時間調整期にタイムスタンプの補正が正しく行われないことがあったバグを修正。
  • 環境によっては終了時に異常終了することがあったバグを修正。

Ver2.12 1998/10/28

  • はじめてインストールしたときプレビュー画面の表示色の初期値がすべて黒になっていた不具合を修正した。

Ver2.11 1998/10/01

  • プレビューウインドウで文字と罫線、背景色の変更。
  • プレビューウインドウを開くときのサウンドファイルを終了時とは別に指定可能に。
  • フォルダオプションで「拡張子を表示する」にしている場合にもCopyToファイルの拡張子(.cp2)を隠す設定を追加した。

Ver2.1 1998/09/04

  • 正式リリース版。
  • フォルダの更新で複数フォルダをまとめて処理可能になりました。
  • CopyToの各種設定をファイルに保存することにより、操作性を改善しました。
  • 更新処理に「Think Different」モードの追加しました。
  • プレビューウインドウから右クリックでファイルのプロパティを開くことが可能になりました。
  • プレビューウインドウの表示オプションに「罫線を表示」を追加しました。
  • 履歴のクリアで項目ごとのクリアが可能になりました。
  • フォルダの「指定フォルダを除く」設定の操作性を改善しました。
  • NTFSとFATのドライブ間で「処理元とターゲットの間で互いにBackup」モードを実行するたびに特定のファイルがコピー対象になることがあったバグを修正しました。

Ver2.0 1998/06/01

  • 正式リリース版。
  • 「処理前にプレビューウインドウを表示する」の初期値を表示するに変更しました。
  • 「上書き、削除で確認する」の初期値を確認しないに変更しました。
  • ゴミ箱は自動で処理対象から除きます。
  • フォルダの属性もフォルダ作成時に複写するように改善しました。
  • 使用中のファイルに対して再試行が可能となりました。

Ver1.38 1997/12/01

  • SSLで暗号化されたホームページからシェアウエア登録が可能になりました。
  • 機能改良。

Ver1.37 1997/11/10

  • 更新モードでターゲットディスクの空き容量によっては「floating point error」で異常終了していたバクをフィックス(Ver1.35からのバグ)。
  • コマンドラインからの起動オプションで相対パスをサポートするなど操作性を改善しました。

Ver1.36 1997/10/29

  • 更新モードの確認ウインドウでのバイナリ比較機能のバクフィックス。

Ver1.35 1997/10/25

  • 更新モードでの次の機能を追加した。
  • システム属性フォルダも処理対象とする。
  • 確認ウインドウの右クリックでソースとターゲットのファイルをバイナリ比較して相違があるかを表示する。
  • 確認ウインドウでターゲットディスクの空き容量の再表示機能。
  • エラーメッセージの強化などの機能改良。

Ver1.34 1997/09/29

  • 更新モードに増分バックアップ(アーカイブ属性のファイルをコピーして、コピー元のアーカイブ属性を解除する)を追加。

Ver1.33 1997/09/13

  • 同期モードで指定フォルダを処理対象から除く機能が正しく動作しないことがあったバグの修正。

Ver1.32 1997/09/03

  • 参照ボタンの表示上のバグ修正。

Ver1.31 1997/08/30

  • 次の環境で更新を実行するたびに特定のファイルがコピー対象になることがあったバグを修正。(処理元のディスクがNTFS、ターゲットのドライブがFATの場合)
  • 更新モードでの次のオプションを追加した。
    - システムと隠し属性のファイルを処理対象から除く。
    - 削除でゴミ箱に移動するかどうか。
  • その他の機能改良。

Ver1.23 1997/07/25

  • 次の環境で更新を実行するたびに更新日付の奇数秒のファイルがコピー対象になることがあったバグを修正。(NT4.0で処理元のローカルディスクがNTFS、ターゲットのネットワークドライブがFATの場合)
  • ファイルの更新でも進行状況ダイアログにアニメーションを表示するようにした。

Ver1.22 1997/06/25

  • 今までリストボックスで選択しなければならなかった処理モードをワンタッチで変更できるようにした。コピー(Ctrl+C) 削除(Ctrl+D)...など。

Ver1.21 1997/06/01

  • 正式リリース。

Ver1.2 beta2 1997/05/20

  • 「画面のプロパティ」のフォントサイズの設定によっては正しく表示できなかった不具合を修正。

Ver1.2 beta1 1997/05/12

  • 更新モードの処理ファイルの確認ウインドウで次の機能を追加した。
  • 項目ごとに桁をそろえて見やすく。
  • ファイルサイズと更新日時の表示の追加。
  • ステータス行に現在選択している各処理別のファイルサイズの合計とターゲットに必要な容量の表示。
  • 右クリックで選択しているファイルを関連づけられたアプリケーションから開く。
  • チェックのON/OFFでウインドウ全体を再描画しないように。
  • コマンドラインから起動でデバイスの準備ができていないときリトライの確認をする。
  • その他の機能改良。

Ver1.11 1997/03/15

  • Service Pack 2をインストールしたWindowsNT4.0で正常な動作を確認した。
  • 更新モードの対象から除くフォルダの追加で「すでに指定されている」というメッセージがでることがあったバグの修正とエクスプローラからのドラッグアンドドロップでも可能とした。
  • その他の機能改良。

Ver1.10 1997/02/23

  • 更新モードでの次の機能を追加した。
  • ファイルの処理制限でのワイルドカードの指定。
  • サブフォルダを対象にしない。指定のフォルダを対象としない。
  • 確認ウインドウに置換ファイルのタイムスタンプの表示などを追加。その他の機能改良。

Ver1.04 1997/01/18

  • コマンドラインから起動したとき、更新モードで対象ファイルの制限の処理が動作しないことがあったバグを修正した。
  • その他の機能改良。

Ver1.03 1997/01/05

  • 更新処理で処理ファイル名の表示と処理経過の表示。
  • 処理前にターゲットのドライブの存在を確認。
  • メニューなどの表示を可能な限り日本語に。
  • アンインストールでスタートメニューの[Copyto]グループを削除するようにした。
  • その他の機能改良。

Ver1.02 1996/12/19

  • 更新モードでの処理速度のアップ。機能改良。

Ver1.01 1996/12/08

  • 機能改良。正式版。

Ver1.00 1996/12/04

  • ショートカットの作成機能の追加。

Ver0.91 1996/12/01

  • 機能追加、改良とバクフィックス。

Ver0.51b 1996/11/15

  • 更新処理の同期モード：ターゲットフォルダでソースフォルダに存在しないフォルダを削除する処理を追加した。

Ver0.51a 1996/11/12

  • 更新処理の同期モードでのバグ修正。

Ver0.51 1996/11/08

  • WindowsNT4.0に暫定対応。

Ver0.50 1996/08/30

  • 初版


11

■11